PHP is amongst the most commonly used object-oriented programming languages. It is rather popular as it’s free software, which can be used to develop interactive sites like community portals, shopping portals or e-learning portals instead of static HTML-based websites. A PHP module should be available on the server where a PHP-powered website is hosted so that its code can be interpreted. Since there are no license taxes for this kind of module and the language offers unlimited options for the Internet apps that you create, there are hundreds of millions of PHP sites. On top of that, there’re heaps of open-source PHP scripts, which you can use for your websites without needing to have any coding knowledge. As there’re a few versions of PHP, you ought to make certain that the very same version that you used whilst building your site is present on the server too.

PHP 4 and PHP 5 Support in Cloud Website Hosting

If you order a cloud website hosting package from our company, you will never have to ponder on whether or not your websites are compatible with the hosting environment, as several versions of PHP are installed on our servers for your convenience. The Hepsia hosting Control Panel will permit you to select PHP 5.5, 5.4, 5.3, 5.2 or 4 with only one single mouse click and if you wish to change the version, the new settings will be applied right away. In this way, several years of work on sites built with an older PHP version won’t be lost. Our web hosting platform will even permit you to use a different PHP version for each domain hosted in your account, which suggests that you can run newer and older scripts simultaneously. Most web hosting companies on the market offer support for one, sometimes for two PHP versions. In stark contrast to them, we are strongly convinced that you should be the one to select the version that your very own websites will use.

PHP 4 and PHP 5 Support in Semi-dedicated Servers

We’re of the firm opinion that several years spent creating a site should not be lost, which implies that in case you buy a semi-dedicated server from us, you will be able to use any script, no matter if it is new or old. In stark contrast to a lot of web hosting companies, we support a number of different versions of PHP on our leading-edge cloud web hosting platform – 4, 5.2, 5.3, 5.4 and 5.5. Not only will you have the ability to activate the needed version via your Hepsia Control Panel, but you’ll also have the possibility to pick a different version for each website. The latter can be done merely by placing an .htaccess file in the root directory of the given site. You can change the current version not only for a single site, but also for the entire account and the new settings will be applied in just several minutes. With our hosting services, you can be certain that you will never confront any site incompatibility complications.